まくろぐ
更新: / 作成:

認証スキーム とは、HTTP のリクエストヘッダに指定する Authentication ヘッダーの先頭部分に指定する文字列のこと。

  • Basic … RFC2617
    • Web ブラウザが標準でサポートしている。
  • Bearer … RFC6750
    • OAuth 2.0 で使われている認証スキームのひとつ。
    • 署名を行う必要はなく、受け取った値をそのまま使える。
  • Digest … RFC2617
    • Web ブラウザが標準でサポートしている。
  • Negotiate … RFC4559
  • OAuth … RFC5849
    • OAuth 1.0 で使われていた認証スキーム。
    • 署名のルールが複雑すぎて廃れた。

参考リンク

関連記事

まくろぐ
サイトマップ | まくへのメッセージ